Vista Style Builder

   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Window title background - 8.1 preview  (Read 30170 times)
drakkar1969
Beginner
*
Posts: 59


View Profile
« on: September 02, 2013, 01:03:22 pm »

Working on windows 8.1 preview theme. When I modify DWM window frames, the background of the window titles does not get themed (you can still see colorization color from aero theme). This only happens on non-ribbon windows (other windows are fine)



Any idea how to work around this? Thanks
Logged
Panda X
Administrator
Dedicated Helper
*****
Posts: 1627



View Profile
« Reply #1 on: September 02, 2013, 01:17:55 pm »

The only way is to set the colorization color to the same as the image.
Logged
drakkar1969
Beginner
*
Posts: 59


View Profile
« Reply #2 on: September 02, 2013, 06:54:25 pm »

thanks
Logged
Mr GRiM
Beta Tester
Dedicated Themer
*
Posts: 304


Master Theme Builder


View Profile
« Reply #3 on: September 02, 2013, 07:17:51 pm »

This will be fixed with Aero Glass by Big Muscle, I am using the beta for it now and it removes that background in the title text.
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2100



View Profile
« Reply #4 on: October 22, 2013, 11:56:50 pm »

Just in case this is still an issue for some people here's a fix in more detail:

This only works if your frames have a solid color.

1) Go to Fonts, Colors, & System Metrics > Colors (Globals) and change the COLORIZATIONCOLOR:INT using this tool:

http://vistastylebuilder.com/forum/index.php?topic=1187.0


2) Go into your theme file. Change AutoColorization to equal zero and then add a ColorizationColor that is exactly the same as the one you added in the first step

For example:  

1) I have a white top frame so I wanted a white text background. I put 0XFFFFFFFF or a solid white in argb hex values and received an Int of -1 which I used in Colors(Globals).

(the a in argb is the amount of transparency. The value varies from 0 or 00 which is totally transparent to 255 or FF which is totally opaque).

2) I then went into my theme file and put this:

AutoColorization=0
ColorizationColor=0XFFFFFFFF


Now the Title Bar text background always matches the frame color when I apply my theme:


« Last Edit: March 22, 2014, 09:51:51 pm by 3am » Logged
Nighthawk-f22
Beginner
*
Posts: 24


View Profile
« Reply #5 on: October 23, 2013, 08:57:18 am »

Thanks
It would be nice if you could find a way to add back the white text glow on non ribbon borders.
I am not so keen about Aeroglass.
It looks great, but it has some downside with security like no support for UEFI Boot.

Regards Nighthawk
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2100



View Profile
« Reply #6 on: October 23, 2013, 04:01:09 pm »

Yeah it's too bad the Windows & Caption Buttons > Aero > DWM Window > Frames > Details > Glows > Text image doesn't show anymore no matter what you do with it Sad


Logged
leafleaf
Beginner
*
Posts: 5


View Profile
« Reply #7 on: November 02, 2013, 05:51:03 pm »

Hello, (sorry for for hijack the thread)   

But what should I do if I my top frame use image(with gradient) instead of just a color value?



I currently use blank font as temporary fix, but a proper way to fix is still greatly appreciated. Cheesy
Big thanks in advance!
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2100



View Profile
« Reply #8 on: November 02, 2013, 09:35:59 pm »

You'd have to use this: 

http://www.msfn.org/board/topic/163570-aero-glass-for-win81-rtm-beta-3/
Logged
leafleaf
Beginner
*
Posts: 5


View Profile
« Reply #9 on: November 03, 2013, 02:12:11 pm »


Thank you as always!
Sad that it require another extra app.  : (
Logged
Nittiyh
Beginner
*
Posts: 13


View Profile
« Reply #10 on: November 22, 2013, 11:44:06 pm »

Thank you for the trick 3am. Works perfect.
Logged
ezio84
Beginner
*
Posts: 36


View Profile
« Reply #11 on: December 10, 2013, 11:52:18 am »

Just in case this is still an issue for some people here's a fix in more detail:

cut
I was getting crazy, thank you mate!!
Logged
Udzi
Beginner
*
Posts: 13


View Profile
« Reply #12 on: December 11, 2013, 03:11:28 pm »

1) Go to Fonts, Colors, & System Metrics > Colors (Globals) and change the COLORIZATIONCOLOR:INT using this tool:
2) Go into your theme file. Change AutoColorization to equal zero and then add a ColorizationColor that is exactly the same as the one you added in the first step

For example: 
1) I have a white top frame so I wanted a white text background. I put 0XFFFFFFFF or a solid white in argb hex values and received an Int of -1 which I used in Colors(Globals).
(the a in argb is the amount of transparency. The value varies from 0 or 00 which is totally transparent to 255 or FF which is totally opaque).
2) I then went into my theme file and put this:

AutoColorization=0
ColorizationColor=0XFFFFFFFF

Hi Guys,

today i've started play theming 8.1 with a already existing theme: Embed8. The Theme was created for Windows 8, so the Problem with the Title Background exists (see screenshot)



I've followed every in 3am's detailed instruction, know my colorization: (0xFF525252 / -11382190) and added it to the COLORIZATIONCOLOR:INT, but now im stuck... Cry
Where has the AutoColorization=0 & ColorizationColor to be placed?

If this works, the White glow is gone, so I'd also like to have a White font instead of the black one. Where to change that?
I've added the Theme as attachment.

Thank You Guys.
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2100



View Profile
« Reply #13 on: December 11, 2013, 04:10:18 pm »

1) Change the AutoColorization and add the ColorizationColor to your .theme file like this:




2) Change the textcolor at:

Windows & Caption Buttons > Aero > DWM Window > Frames > Window > Top > Inactive
« Last Edit: December 11, 2013, 04:14:53 pm by 3am » Logged
Udzi
Beginner
*
Posts: 13


View Profile
« Reply #14 on: December 11, 2013, 04:18:45 pm »

First of all, thank you 3am to your fast reply. But...you must think i'm totally stupid  Huh? i don't get it where to put these values (see my screenshot).



Could you edit my theme from the upper attachment, add these values & and a white font so i can learn from it? THAT WOULD BE GREAT!

Thanks
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2100



View Profile
« Reply #15 on: December 11, 2013, 05:05:17 pm »

I had already added that to my 7 theme before I ported it to 8. You can't add anything there anymore.

In your msstyles I changed the textcolors to white at

Fonts, Colors, & System Metrics > Fonts & System Metrics > CAPTIONTEXT:COLOR
Fonts, Colors, & System Metrics > Fonts & System Metrics > INACTIVECAPTIONTEXT:COLOR

and added a white textcolor to Windows & Caption Buttons > Basic > Frames > Window > Top

If you just want to change the text where that background was then just keep the INACTIVECAPTIONTEXT white

I also changed your theme file. I attached them here.

Sorry for the confusion
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2100



View Profile
« Reply #16 on: December 11, 2013, 05:28:54 pm »

I was just looking at your msstyles and noticed you forgot to change your ColorizationColor in Fonts, Colors, & System Metrics > Colors (Globals).

So I changed it for you and attached the msstyles here
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2100



View Profile
« Reply #17 on: December 11, 2013, 05:49:39 pm »

I just checked your inactive frame color and I'm getting 0XFF9C9C9C or a ColorizationColor INT of -6513508 which is what you need not the numbers you quoted.

So I'm attaching your msstyles and theme file with the correct numbers
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2100



View Profile
« Reply #18 on: December 11, 2013, 06:27:08 pm »

Forget it. Your inactive top frame has transparency, This method only works on solid color frames.

You'll have to use this:   http://www.msfn.org/board/topic/163570-aero-glass-for-win81-rtm-beta-3/
Logged
Udzi
Beginner
*
Posts: 13


View Profile
« Reply #19 on: December 11, 2013, 06:37:12 pm »

Ok thank you very much! Is there an option to make my theme non-transparent? I don't want the transparency anyway OR to remove the Text and background completely (that would be an option to me)?
« Last Edit: December 11, 2013, 06:38:58 pm by Udzi » Logged
Mr GRiM
Beta Tester
Dedicated Themer
*
Posts: 304


Master Theme Builder


View Profile
« Reply #20 on: December 11, 2013, 11:42:37 pm »

Ok thank you very much! Is there an option to make my theme non-transparent? I don't want the transparency anyway OR to remove the Text and background completely (that would be an option to me)?

Yes you can remove the text completely if you use a blank font.
Logged
Udzi
Beginner
*
Posts: 13


View Profile
« Reply #21 on: December 12, 2013, 08:34:40 am »

Thank you 3am & Mr Grim for your Replies. I changed the Font to blank and resized it to the smallest size (1pt). This is what i get



That ist what i can live with. the small grey line doesn't disturbe.
Logged
Jamie
Beginner
*
Posts: 87


Theme designer


View Profile WWW
« Reply #22 on: January 04, 2014, 11:27:03 pm »

I know this is old but I'm working on some Windows 8.1 themes and I have a VM setup for themeing since it's pretty buggy right now.
Anyhow, on my VM when I use the blank font trick it works perfect, however on my everyday machine it still displays the text.  It's really bugging me. :-D

Here's a pic of what I'm talking about.  The exact same blank font is installed on both machines.



Here's the theme for 8.1

http://sta.sh/01mc4i8gpznf

Any thoughts or help would be awesome.
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2100



View Profile
« Reply #23 on: January 04, 2014, 11:49:00 pm »

I tested your msstyles and works perfectly here
Logged
Jamie
Beginner
*
Posts: 87


Theme designer


View Profile WWW
« Reply #24 on: January 05, 2014, 12:03:16 am »

Thanks for taking the time to test it 3am.  Much appreciated.  I forgot to mention I hadn't had WSB installed on my main machine.  I thought for the hell
of it I would install it and test a theme and now it and another theme I had the same problem with work with the blank font fix...wierd.
So unless you have WSB installed the blank font trick does't seem to work for some reason.
I'm glad it fixed it but the general public who use my theme won't get the benefits of the blank font fix.  I'll try doing some more testing to see if I'm right or not.

btw it's neiio over at dA, not that it makes a difference. :-D
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2100



View Profile
« Reply #25 on: January 05, 2014, 01:24:18 am »

Try saving it and using it with WSB. Then apply it in Personalization
« Last Edit: January 05, 2014, 01:37:48 am by 3am » Logged
Panda X
Administrator
Dedicated Helper
*****
Posts: 1627



View Profile
« Reply #26 on: January 05, 2014, 01:29:30 am »

The sysmetrics properties aren't applied via the control panel anymore in 8.
Logged
Jamie
Beginner
*
Posts: 87


Theme designer


View Profile WWW
« Reply #27 on: January 05, 2014, 03:28:13 am »

Thanks Panda, I'm guessing a .reg hack might do the trick?
Logged
Jamie
Beginner
*
Posts: 87


Theme designer


View Profile WWW
« Reply #28 on: January 05, 2014, 04:33:19 am »

I found a hack.  It ain't pretty, I'm no coder by any means. Cheesy

Just a reg file to make your Windows text blank, 1
And a default to return the text to normal.

You'll have to log off and on again to notice the changes.

http://sta.sh/08ccm9ua7dr
« Last Edit: January 05, 2014, 04:44:16 am by Jamie » Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2100



View Profile
« Reply #29 on: January 05, 2014, 01:53:49 pm »

I just applied your theme through Personalization. I didn't use WSB or the registry hack. And it worked fine:


« Last Edit: January 06, 2014, 01:43:24 am by 3am » Logged
Jamie
Beginner
*
Posts: 87


Theme designer


View Profile WWW
« Reply #30 on: January 07, 2014, 10:19:18 pm »

Thanks 3am.  I only had to use the registry hack on the system that didn't have WSB installed on it for some reason.
Logged
link6155
Beginner
*
Posts: 63



View Profile
« Reply #31 on: January 07, 2014, 11:45:30 pm »

I found a hack.  It ain't pretty, I'm no coder by any means. Cheesy

Just a reg file to make your Windows text blank, 1
And a default to return the text to normal.

You'll have to log off and on again to notice the changes.

http://sta.sh/08ccm9ua7dr

I tried your registry tweak on my theme and it mostly fixed the problem, but there's a "-" there now:


Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2100



View Profile
« Reply #32 on: January 08, 2014, 12:39:49 am »

1) Theme your Windows & Caption Buttons > Aero > DWM Window > Frames > Shadowless Window > Normal > Bottom & Top images

2) Uncheck "Show Shadows Under Windows" at Control Panel\All Control Panel Items\System \Advanced System Settings

and you won't see that anymore or need the registry hack
Logged
Jamie
Beginner
*
Posts: 87


Theme designer


View Profile WWW
« Reply #33 on: January 08, 2014, 02:28:59 am »

Or you can try this, in your .theme file put this for your

AutoColorization=0
ColorizationColor=0XFF333333
« Last Edit: January 08, 2014, 02:35:13 am by Jamie » Logged
link6155
Beginner
*
Posts: 63



View Profile
« Reply #34 on: January 08, 2014, 04:05:40 am »

1) Theme your Windows & Caption Buttons > Aero > DWM Window > Frames > Shadowless Window > Normal > Bottom & Top images

2) Uncheck "Show Shadows Under Windows" at Control Panel\All Control Panel Items\System \Advanced System Settings

and you won't see that anymore or need the registry hack

This would technically work, but my theme uses the shadow as part of the border to achieve the round corners.

Or you can try this, in your .theme file put this for your

AutoColorization=0
ColorizationColor=0XFF333333
It's a temporary fix, but it doesn't quite work when the windows inactive in my theme.

I have no problem with the blank font when testing the theme in WSB, but when other people try it, the text still shows even if they have the blank font installed.
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2100



View Profile
« Reply #35 on: January 08, 2014, 02:20:03 pm »

Did you change your COLORIZATIONCOLOR:INT in Fonts & System Metrics > Colors(Globals) to -13421773 as well as adding

AutoColorization=0
ColorizationColor=0XFF333333

to your .theme file as Jamie said?

« Last Edit: January 08, 2014, 09:35:41 pm by 3am » Logged
Panda X
Administrator
Dedicated Helper
*****
Posts: 1627



View Profile
« Reply #36 on: January 09, 2014, 12:32:55 pm »

Did you change your COLORIZATIONCOLOR:INT in Fonts & System Metrics > Colors(Globals) to -13421773 as well as adding

AutoColorization=0
ColorizationColor=0XFF333333

to your .theme file as Jamie said?



That's just redundant.
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2100



View Profile
« Reply #37 on: January 09, 2014, 02:51:23 pm »

Yeah. Ok. Never mind
« Last Edit: January 09, 2014, 10:11:34 pm by 3am » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.12 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!